Cluster Chart Sync with Make generating "NaN%" Data Label

I am having trouble generating dynamic cluster charts through Make.
The weird thing is that when I input the exact same data from the Chart Maker everything looks good. But when I enter through the URL generated by Make all the data laberl are changed to “NaN%”.

Link to the Make-generated chart

Link to the Chart Maker with the same preloaded data

It seems the chart template does not correctly save the setting “use “Z” value as label”

Hi @RookieInvestor,

Looks like there was an issue with the way “Use Z value as label” persists in combination with data label formatting.

We’ve deployed a fix. Here’s your fixed chart. You’ll have to edit & re-save any other charts you made.

Please let me know if you run into any other problems!